Experiment with the following two commands:


git ls-remote -h -t git://github.com/ably-forks/msgpack-js.git
git ls-remote -h -t https://github.com/ably-forks/msgpack-js.git


If the first one works, but the second one hangs or fails, you can try configuring git to always fetch dependencies using the git protocol rather than https, by doing:


git config --global url."git://".insteadOf https://


Then try installing ably-js again.