This error is an indication that you're using a 'thin jar' (a jar file containing just ably-java) without installing its dependencies. This won't work; instead, you should follow the installation instructions at https://github.com/ably/ably-java#installation