We used to allow non versioned use of our CDN to serve our Ably Realtime Javascript library so that anyone wanting the latest version of the client library could omit the version from the URL and be guaranteed the latest stable release.  An example of an old style CDN URL without a version is http://cdn.ably.io/lib/ably.min.js


These non-versioned URLs however are no longer supported.  The reason behind this is that if we need to release a breaking change in the Javascript library (like we did for our v1.0 release), we cannot do that safely without potentially breaking existing apps using the non-versioned Javascript file from our CDN.


So in order to ensure Ably can guarantee no breaking changes via our CDN, customers must now choose to lock into a specific major, minor or patch version according to the Semantic Versioning scheme.


For example: